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Chapter 1 - Getting Started 

1.1 Introduction 

Thank you for your purchase of the Wasp Labeler barcode creation software.  This topic contains 
information that will help familiarize you with barcodes and show you how to create customized 
barcodes.  The Introductory Materials section contains important information you should familiarize 
yourself with prior to creating barcodes.   
  
Introductory Materials 
  
Wasp Labeler Capabilities 
What is a Barcode? 
Navigating the Main Screen 
Creating a Static Label 
Binding a Data Source to an Object 
Using String Builder to Concatenate Data 
Example Labels 
Barcode Symbology Reference 
  
After you have read the introductory materials, you are ready to start using Wasp Labeler.  Click on the 
link below to go to the next step in the Getting Started section. 
  

 
Software activation system licensed under Patent No. 5,490,216 
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1.2 Getting Started - Wasp Labeler Capabilities 

Wasp Labeler is a professional label generation application designed to meet the most 
demanding barcode labeling and printing requirements. Easily generate barcode labels, asset or 
inventory labels, address labels and envelopes with PostNet Zip Codes, ID badge labels, 
business checks, and date and time stamps for perishable goods, then print your labels from 
any local or network Windows printer. You can import data directly from your corporate 
databases or you can create a new Microsoft Access database. In addition, Wasp Labeler can 
generate compliance labels for practically every industry. 
  
Wasp Labeler: 

  
 Supports the following barcode languages: 

 
AztecCode, Codabar, Code 128, Code 39, Code 93, DataMatrix, EanJan13, 
EanJan8, Interleaved2of5, Isbn, Itf14, MaxiCode, MicroPDF417, MicroQRCode, Msi, 
PDF417, Postnet, QRCode, GS1, GS1Stacked, GS1Omnidirectional, GS1Truncated, 
GS1Expanded, GS1Limited, UCCEAN128, UPC-A, UPC-E 
 
For a description of each of these symbologies, please refer to the Barcode 
Symbology Reference. 
  

 Prints the most popular 2D barcodes: 
 
DataMatrix, MaxiCode, MicroPDF, MicroQRCode, PDF417, Aztec Code and 
QRCode 
  

 Supports any laser, dot matrix, thermal or ink jet printer using a standard Windows 
printer driver. 
  

 Allows you to edit multiple labels concurrently. 
  

 Allows you to input data on the label at print time. 
  

 Capable of advanced graphic resizing and graphic rotation. 
  

 Allows import of bitmap files (*.bmp), JPEG (*.jpg, *.jpeg, *.jpe, *jfif), PNG (*.png), 
TIFF (*.tiff, *.tif), GIF (*.gif), ICON (*ico). 
  

 Allows connecting to external databases: 
 
Microsoft Access, Microsoft SQL Server, ODBC data sources, 
QuickBooks® as well as comma separated files or other delimited text files.  
  

 Allows import of text files or Microsoft Excel worksheets. 
  

 Allows import of QuickBooks® data (version 2008 or later). 
  

 Includes over 100 label layout templates. 
  

Wasp Labeler supports drawing objects including text, lines, rectangles, ellipses, and barcodes. 
Each of these drawing objects has full edit capabilities including draw style, size, position and 
color.  In addition, practically any picture can be imported onto the label design, linked to the 
original file, or retrieved from a database. 
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3 

Wasp Labeler supports Static, Serialization, Prompt at Print Time, External Data Source, Bind to 
Another Object, and Date/Time for objects. The 'Prompt at Print Time' feature is used to 
interactively enter information onto the label at print time. The 'External Data Source' feature 
allows you to import, view, and edit information from the most common databases and allows 
your Text and Bar Code objects to retrieve their source value from an external file. In addition, 
Wasp Labeler provides the capability to quickly create your own database.  
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1.3 Getting Started - What is a Barcode? 

A barcode is a graphical representation of a set of numeric or alphanumeric characters that can be read 
by a barcode scanner.   

1234 becomes: . 

Whse1 becomes: . 
  
Assigning a permanent barcode to each site, location, item, supplier and customer creates an 
environment where a mobile device can be used to easily keep track of inventory movements and 
alleviates the problem of data-entry errors. 
  
Barcodes get wider with the amount of numbers and characters you want represented by them.  In 
other words, the width is determined by the amount of numbers or characters represented by the 
barcode.  Some barcode scanners have a limited width that they can read.  If you have very long item 
numbers or location numbers you may need to reconsider the numbering scheme or the scanner you 
are using.  Also be aware that many of the less expensive barcode readers do not read barcodes that 
are bent, at an angle, are too small or are damaged.  Consider the possible disposition of your 
barcodes before choosing a scanner. 
  
There are many different barcode formats or symbologies.  The different symbologies can be thought of 
as different fonts.  The same characters are represented by different symbologies in different ways.  For 
example, the two symbologies below represent the same information (Whse1). 
  

 

 
These different formats exist to provide ways to compress more data into a smaller space, to represent 
a different set of characters or to enable scanning at different angles or distances.  
  
When using Wasp Labeler, barcodes should be printed using a high quality laser or ink jet printer, or a 
thermal label printer.   You want the barcode label to be high quality because low quality barcodes are 
harder to scan and usually do not last long.  Wasp Labeler can print to a regular printer or a barcode 
printer.   
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1.4 Getting Started - Navigating the Main Screen 

In this topic: 
  
Help/Resizing Icons 

Accessing Help 
Resizing/Minimizing Wasp Labeler 

Tabs 
Icon Toolbar 
Design Window 
Properties Box 

Hide/Show the Properties Box 
Move the Properties Box 

  
This topic provides a brief overview of Wasp Labeler's Main screen.  The Main screen provides access 
to all of the features and functions you will need to create customized labels or to create labels using 
the  templates. Use this topic to help familiarize yourself with getting around in the application.  Links to 
detailed instructions for using each function are provided throughout this topic. 
  

 
  
A: Help/Resizing Icons 
B: Tabs 
C: Icon Toolbar 
D: Design Window 
E: Properties Box 
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1.4.1 Section A: Help/Resizing Icons 

This section contains icons that allow you to adjust the size of the Labeler screen, access this Help file 
or close the Labeler window. 

Accessing Help 

Launching the Help File: You can launch this Help file from anywhere in the Labeler application 
by clicking the question mark icon in the top right of the screen.  Using this method launches the 
Help with the topic related to the currently open screen/tab displayed.  You can search for or 
navigate to other topics as needed. 
 

 
  
Context-Sensitive Help: You can access a Help topic specific to the screen or feature you are 
currently using by clicking on the small question mark arrow that appear on most screens and in the 
Properties box.  Clicking the Help icon on the Properties box launches Help specific to the object 
you have selected.  You can also launch context-sensitive help by hitting the F7 key on your 
keyboard. 
 
Help Button Example - Screen 
 

 
 
Help Button Example - Properties Box 
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Resizing/Minimizing Wasp Labeler 

Wasp Labeler can be resized to fit your whole screen or reduced to appear as a portion of your 
screen.   
  
To resize the window, click the icon in the top, right of the Main screen, as shown below: 
  

 
  
The screen will reduce in size when the icon is clicked.  You can resize the screen by dragging any 
of the corners or borders.  Labeler will remember the size when it is closed and re-opened. 
  
To minimize the screen and place it on the taskbar, click the minimize icon in the top, right of the 
Main screen, as shown below: 
  

 
  
Labeler will be placed on your taskbar.  To reopen it, click on the icon on your taskbar. 
  

 

1.4.2 Section B: Tabs 

File Tab: 

The File Tab contains save, open, and close options.  This tab also allows you to launch example 
labels and  check for updates to your software.  Click on an icon to access a function.   

Design Tab: 

The Design Tab contains all of the options for customizing your label.  Click on an icon to access that 
function.  The toolbar on this tab is divided into 5 sections: 
  
Clipboard - This section contains basic commands such as Cut, Copy, Paste, Undo and Redo. 
Insert - The Insert options allow you to insert text, basic shapes, a picture or a barcode into your label. 
Arrange - The Arrange menu allows for precision placement of objects or text you insert onto your 
label. 
Layout Options - Use these options to change the layout of your label or to hide/show the ruler along 
the top and side of the label. 
View - The View menu allows you to zoom in or out. 
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Changes you make will appear in the Label Design window. 
  

Data Tab: 

The Data Tab allows you to add a database, spreadsheet, .csv file or other data source to your label 
project.  You can then associate an object on your label, such as a text field or a barcode with the data 
source. 
 

 

Print Tab: 

The Print Tab contains functions relating to printing your labels, including Page Layout. 
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1.4.3 Section C: Icon Toolbar 

The tabs at the top of the Main screen allow you to switch between functionalities.  The tabs act as a 
way to group Wasp Labeler's features together by task.  For instance, the File tab contains functionality 
related to opening a new file, closing a file, saving a file, etc., while the Design tab contains 
functionality related to creating and designing your labels.  When you first open Wasp Labeler, the 
Design tab is displayed and this is the tab you will probably use the most.   
 
You can switch to a different tab by clicking on the desired tab label. 
 

 
 

  

1.4.4 Section D: Design Window 

The Wasp Labeler Design window, by default, shares space on the Main screen with the Properties 
box.  You can Hide the Properties box entirely, or you can resize the Design window as needed.  To 
resize the window, place your mouse over the dividing line between the Design window and the 
Properties box until your cursor turns into a double arrow, as shown below: 
  

 
  
With the left button held down on your mouse, drag the dividing line either left or right.  Keep in mind 
that you cannot expand the Design window over the Properties box.  When the Design window 
reaches it's maximum width, it will stop moving.  If you need more design area, hide the Properties 
Box. 
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1.4.5 Section E: Properties Box 

The Properties box contains options specific to the type of object you have selected in the Design 
window (barcode, text box, picture or drawing object).  You can hide the Properties box or "dock" it in a 
different location as needed. 

Hide/Show the Properties Box 

The Properties box is displayed on the Main screen by default.  This box displays information 
relating to the tab you are currently using.  For example, on the Design tab, the Properties box 
displays the various options available to the selected object..  If you want to have a larger design 
area, you can hide the Properties box by clicking on the Pin icon in the right-hand corner of the box, 
as shown below: 
  

 
  
When the Properties box is hidden, a label will appear on the right side of the screen as shown 
below: 
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Move the Properties Box 

By default the Properties Box is docked on the right side of the Labeler screen.  You can move, or 
redock, the Properties Box to the center-left, center-right or left side of the screen as needed. 
  

1. Click on the top of the Properties Box and drag it.  The box will undock from it's current 
location and appear as a small, floating box similar to the example shown below: 
 

 
2. Drag the box to the center or left of the screen.  Arrows appear on the screen showing you all 

dockable locations as shown below: 
 

 
  

3. Drag the box to an arrow..  The screen will highlight yellow indicating the area in which the 
box will appear if docked there.  In the example shown below, the box would appear from the 
center of the window to the right. 
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 You can then let go of the box and it will dock where indicated. 
 
To move the Properties box back to the default location, click the Reset Docking icon on 
the Label Tab toolbar. 
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1.5 Getting Started - Creating a Static Label 

Now that you are familiar with the basics of moving around the Main screen, you can begin creating 
your labels.  This topic will take you through the steps to create the most basic label - a static barcode 
label.  A static label means the information on it does not change.  The label does not pull information 
from a database, isn't serialized, etc.   
  
For this example, we are going to create one name badge label containing a standard Code 128 
barcode and a text field containing a name and employee ID number.  Links are provided in each step 
to detailed information regarding the tabs and screens. 

  
1. Open a document: 

 
Open a New Document and make sure the Design tab is selected.   
  

2. Add a barcode: 
 
Click on the barcode icon and drag it to the Design window. 
 

 
 
You can move the barcode around on your label as needed by clicking on it and dragging it 
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where you want it. 
  

3. Define your barcode: 
 
By default, a Code128 barcode with content123456789 will be placed onto your label.  Use the 
Properties box to select the appropriate barcode and enter the content (what you want 
encoded in the barcode). 
  

a. Make sure the barcode is selected in the Design window. 
  

b. Click the Barcode tab in the Properties box. 
  

c. Make sure Code 128 is selected in the Symbology drop down box. 
 

 
  

d. Enter the data you want encoded in the barcode into the Content box.  In this case, we 
want the employee name and employee ID number so entered Jane Doe123456 into 
the Content box.  
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Note that your label changes to display Jane Doe123456 below the barcode. 
 

 
  

e. Now that we have the content in the barcode, we can specify how it should be 
formatted.  In this case, we want the employee ID number to appear below the 
employee name.  To do this, click the ellipse (...) button to the right of the Content field. 
 The Special Characters menu option appears. 
 

 
 
Place your cursor where you want the break to occur.  Here we will place the cursor 
after the e in Doe.  Then click the Special Characters button.  A list of all available 
special characters appears.  Scroll through the list and select <CR> (carriage return). 
 Now your data will appear as follows: 
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Note: For a description of the ASCII Special Characters, please refer to the topic ASCII 
Special Character Codes. 
 
The barcode on your design label will look similar to the following: 
 

 
 

4. Add additional objects to your label: 
 
You can include additional objects on your label as needed.  In the case of the name badge we 
are creating in this example, a graphic such as a picture of the employee or a company logo 
might be included.  To add objects, you will follow the same steps you used for adding a 
barcode.  Click on the icon of the object you want to add and drag it to your label.   
  

5. Save your label: 
 
It is a good idea to save your label periodically so you won't lose any information in the event of 
an unexpected shutdown.  To save your Label, click the File tab.  Select Save from the toolbar, 
then select a name and location for your label.  You can also save by pressing CTRL + S on 
your keyboard to save the label. 
  

6. Choose the label stock on which you want to print: 
 
When you have your label designed the way you want, you can print it to the label printer of 
your choice.  You can select the label stock on the Print tab.  When you open the Print tab, an 
example of how your label will print is displayed as shown below: 
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The example in the screen shot above shows a layout of 4 labels per page.  To change the 
type of label, click the Layout button on the toolbar.  The Page Setup screen appears: 
 

 
  
 
The Page Setup screen allows you to choose a different label template or create custom 
templates.  The template should match the label stock you are using. For our example label, we 
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want to print just one employee badge for Jane Doe.  Let's assume our example company uses 
a laser printer with Avery name badge labels for the employee badges.   In this case, we should 
select Avery Laser from the Family drop down and Name Badge from the Type drop down. 
 The screen will now look like this: 
 

 
 
Click Done to close the Page Setup screen.  Notice that the Print Preview window changes 
based on the Family and Type of label you selected.  The Properties box indicates that 8 
labels will be printed, because this particular type of label (Avery Name Badge) has 8 labels per 
page.  We just want to print one label, so in the Number of Labels section select Specify and 
enter 1 as shown below: 
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7. Print your label: 
 
Now you are ready to print your label.  Click the Print button on the Print tab toolbar.  The 
standard Windows Print screen will appear allowing you to select a printer. 

  
That's it!  You've created a static barcode label.  You can move on to the next step: 
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1.6 Getting Started - Binding a Data Source to an Object 

Now that you can create a basic label (see Getting Started - Creating a Static Label), let's try binding 
a data source to an object.  This allows you to create one label template, attach a database to it, then 
let Labeler pull information from the database when printing.  For example, if you are creating employee 
badges, you can create one template badge, then bind a database containing all employee names and 
ID numbers to objects on your label.  When printing, Labeler will pull the information from the database 
and place it in the associated (bound) barcode or text box on the badge. 
  
This topic will show you the basic steps for attaching a database to your label using the Static Label you 
created in the previous step. 
 
  

1. Open your label. 
 
On the File tab, select the Open icon.   
 

 
 
Recently opened files will appear in the drop down.  If you see your label listed, click on it to 
open.  If you do not see your label in the list, click Open Files From Folder.  Browse to your 
label and select it.  It will appear in the Design window. 
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2. Select a External Data Source on the Data tab. 
 
We'll add a data source to this project using the Data tab.  Your data source options are listed 
on the Data tab.   
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Select the type of database you want to add.  For this example, we want to add a .txt file that 
contains a list of employee ids, and names so click on Text. 
 

 
 
The Data Source - Text File (delimited) screen appears: 
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Select your file and the associated Delimiter, then click Apply.  For detailed instructions on 
adding a Text file, see the topic Connecting to a Text File. 

3. Bind an object on the label to a column in the data source. 
 
On the Design tab, select the object to which you want to bind data.  The property options for 
the selected object appear in the Properties box. 
 

 
 
Here we have selected the barcode object and want to bind it to the Employee ID column in the 
data source.  On the Properties box > Content tab, click the Database button.  A window 
appears displaying all available columns from the data source. 
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Select the appropriate column from the drop down list and click Done. 
 

 
 
Notice that the Properties Box now indicates that this object is using the Employee ID column 
as the data source. 
 

 

That's all there is to adding a data source and binding an object to it.  You can continue binding 
objects to columns or other data sources (Serialized Numbers or Letters, Data/Time, Etc.) as needed.   
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1.7 Getting Started - Using String Builder to Concatenate Data 

In the previous example we learned how to add a data source to the label project and bind an object to 
a column within that data source.  Now let's learn how to concatenate, or combine, two different 
columns. Joined data is called a "string".  Creating strings allows you to bind data from two different 
columns in your data source to one object.  Continuing the Employee Badge example: we previously 
bound the column containing the Employee ID to a barcode, now let's bind the Employee First Name 
and Employee Last Name columns to a text box. 

  
1. Add a Text Box Object. 

 
Click on the barcode icon and drag it to the Design window. 
 

 
 
The Properties Box updates with options for the text box. 
 

2. Create a String using String Builder. 
 
On the Properties Box > Content tab, click the String Builder button. 
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The String Builder screen appears. 
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For this example we want to create a string containing two database columns: Employee Last 
Name and Employee First Name.  Let's assume we want the Last Name first, then a comma 
and a space, followed by the First Name.  The result should look like this: 
 
Doe, John 

a. First, select Database Column from the drop down, then click the Add Substring 
button. 
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The Data Source - Database screen appears allowing you to select a column.  
 

b. Select Employee Last Name, then click Done. 
 

 
 
The substring appears in the window as shown: 
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c. Now repeat Steps a and b, but this time select Employee First Name from the drop 
down list and click Done.  Another substring will be added. 
 

 
d. Highlight the substring Column: Employee First Name and select Add Space Before 

in the Substring Properties box. 
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e. Now we just need to add the comma.  To do this, we'll add a static substring with the 
character "," in it.  Select Static from the drop down menu, then click Add Substring. 
 The Static content screen appears.  Enter a comma in the text box provided, then click 
OK. 
 

 
 

f. The Static substring appears in the String list.  Highlight it and click the up arrow icon 
once to move it between the Employee Last Name and Employee First Name 
substrings. 
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g. Notice that your sample data at the bottom of the String Builder screen now shows the 
correct formatting for your data.  Click OK to save your new string.  The Content 
Source for your text box now shows <StringBuilder>. 
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1.8 Getting Started - Creating Enumerated Labels 

A common need when printing labels is a "label counter" or "copy counter".  Counters tell you what 
number out of a set each label represents: i.e. 1 of 12, 2 of 12, 3 of 12, etc.  
  
You can create these counters using a text field and the String Builder screen.  You have four 
counter field options on the String Builder screen: 
  
Label Counter - This counts the number of unique labels. 
Label Total - The total number of unique labels. 
Copies Counter - This counts the number of copies of unique labels. 
Copies Total - The total number of copies. 
  
Example One: Your warehouse wants to create inventory labels for a set of 20 printers.  Each printer 
is the same make and model, but has a unique serial number.  You need a label that has a barcode 
connected to your inventory database containing the inventory number for the printer type, a 
serialized barcode representing the serial number and a label counter.  
  
Steps: 
  

1. Add your Inventory Database to the label project. 
2. Insert a barcode onto your label and connect it to the inventory number column in your 

inventory database. 
3. Insert another barcode and bind it to Serial Number.  Make sure the Last value as next 

print job's seed checkbox is selected on the Serial Number Settings screen. 
4. Add a textbox to your label. 
5. With the textbox selected, click String Builder in the Properties Box > Content tab.  The 

String Builder screen appears. 
6. On the String Builder screen, select Label Counter, then click Add Substring. 

 

 
 
The substring will be added to the list as shown below: 
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7. Now select Static from the drop down and click Add Substring. 

 
The Static window appears. 
 

8. Highlight the sample text and type "of" (without quotation marks), then click OK. 
 

 

9. With your Static substring highlighted in the list, select Add > SPACE Before and Add > 
SPACE After. 
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10. Finally, select Label Total from the drop down list and click Add Substring.  Label Total will 
be added to your substring list.  Your screen should look similar to the following: 
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11. On the Print tab enter 20 in the Number of Labels > Specify field. 
 

 
 
Now your label will look similar to the following: 
 

 
  

 
  
Example Two:  You are sending a shipment to a customer.  The items will be packed into two 
separate boxes.  You need identical labels on each box with a counter indicating 1 of 2 and 2 of 2. 
  
Steps: 
  

1. Create your label as desired 
2. Add a textbox to your label. 
3. With the textbox selected, click String Builder in the Properties Box > Content tab.  The 

String Builder screen appears. 
4. On the String Builder screen, select Copies Counter, then click Add Substring. 

 

 

35 



Wasp Labeler User Manual 

 
The substring will be added to the list as shown below: 
 

 
5. Now select Static from the drop down and click Add Substring. 

 
The Static window appears. 
 

6. Highlight the sample text and type "of" (without quotation marks), then click OK. 
 

 
 

7. With your Static substring highlighted in the list, select Add > SPACE Before and Add > 
SPACE After. 
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8. Finally, select Copy Total from the drop down list and click Add Substring.  Copy Total will 
be added to your substring list.  Your screen should look similar to the following: 
 

 
 

9. On the Print tab enter 2 in the Number of Copies > Manual from User field. 
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1.9 Getting Started - Example Labels 

Wasp Labeler includes a set of example labels that you can access for a quick demonstration of various 
Labeler features.  Choosing an example label is a good starting point for your label design. Review the 
descriptions in the list of example labels and choose one that best fits your needs. 

  
1. On the File tab, select the Example Templates icon. 

 

 
 
The Example Templates screen appears. 
 

 

2. Scroll through the list of available label templates.  Highlight a label to see a preview and 
description.   
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3. To open an example template in the design window, highlight a template and click the Open 
button.  The label will open in the design window. 
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You can click on any of the elements on the label and see their associated properties in the 
Properties box. 
 
You can do a "Save As" function to save the label under a different name and make changes to 
it as needed.  You cannot make changes directly to the label template.  If you try to save 
changes directly to the template file, the following screen appears: 
 

 
 
Click OK on the warning screen to pick a new name and location for your new label. 
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1.10 Barcode Symbology Reference 

Note:  All example barcodes use the Wasp Labeler default default properties unless otherwise noted. 
  

A | C | D | E | G | I | M | P | Q | U 
A 
Aztec Code 

  
Aztec Code is a 2D barcode that can encode up to 3750 characters from the entire 256 byte ASCII 
character set.   This barcode is square with a "bullseye" in the middle.  Aztec Code is becoming 
increasingly popular for use on cell phones and mobile devices.  The transportation industry, 
governmental agencies and commercial entities also employ this barcode.  In the transportation 
industry you will find Aztec barcode on boarding passes printed from the internet or scanned from 
mobile phones.  Commercial entities add this barcode to bills, catalogues and products and encode it 
with information such as date/time/place of purchase, product number, manufacturer information, etc. 
 Aztec barcodes are very dense and can be read even when varying resolutions and some distortion, 
making it ideal for adding to documents that will be faxed or transmitted electronically. 
  
The compact Aztec code core supports symbols from 15×15 (room for 13 digits or 12 letters) through 
27×27. There is additionally a special 11×11 "rune" that encodes one byte of information. The full core 
supports sizes up to 151x151, which can encode 3832 digits, 3067 letters, or 1914 bytes of data. 
 
Aztec Code Example 
  

 
C 
  
Codabar 

  
Codabar is a variable length symbology capable of encoding 16 characters within any length message. 
Codabar can encode six special characters ("+" (plus), "-" (minus), "$" (dollar sign), "/" (slash), ":" 
(colon), and "." (point)) and all numeric digits.  There are also 4 start/stop code choices possible when 
using the Codabar symbology. These characters (A, B, C, or D) must be included at the beginning or 
ending of a string.  Codabar symbology for any new applications today should not be considered except 
under unusual circumstances because it is limited and out-dated. 
  
Codabar is widely used in library systems and blood banks and for some package transport companies. 
  
Codabar Example (No Check Digit) 
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Code 11 

  
Code 11 is used primarily in telecommunications. The symbol can encode any length string consisting 
of the digits 0-9 and the dash character (-). One or more modulo-11 check digit(s) can be included. 
  
Code 11 Example (No Check Digit) 
  

 
  

  
  

Code 128 

  
Code 128 is variable length and encodes the full 128 ASCII character set. Each character is 
represented by 11 modules that can be one of four bar widths. Code 128 is the most easily read code 
with the highest message integrity due to several separate message check routines. Of all the common 
linear symbologies, Code 128 is the most flexible. It supports both alpha and numeric characters easily, 
has the highest number of characters per inch, and is variable length. 
  
Code 128 is widely used in the shipping industry. 
  
The Code 128 character set includes the digits 0-9, the letters A-Z (upper and lower case), and all 
standard ASCII symbols and control codes.  The codes are divided into three character sets: A, B, and 
C.   
  

 Character Set A - Contains capital letters, control characters and digits.   
 Character Set B - Contains all printable characters. 
 Character Set C - Contains only numbers and the FNC1 character. 

  
Code 128 Example 
  

 
  
  
A special version of Code 128 called GS1 (formerly known as UCC/EAN 128) is used extensively 
world wide in shipping and packaging industries.   

  
  
Code 39 

  
Code 39 is variable length and is the most frequently used symbology in industrial bar code systems 
today. The principal feature is to encode messages using the full alphanumeric character set. Three of 
the nine elements (bars) are wide and six elements are narrow. 
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Code 39 Extended (Full ASCII Code): Standard Code 39 contains only 43 characters (0-9, A-Z, $, /, %, 
+). Code 39 can be extended to an 128 character symbology (full ASCII) by combining one of the 
special characters ($, /, %, +) with a letter (A-Z) to form the characters that are not present in the 
standard Code 39 symbology. For example, in standard Code 39 a lowercase "a" cannot be 
represented. In Code 39 Full ASCII, however, "a" is represented as "+A". 
  
Code 39 Example (No Check Digit) 
  

 
  

  
  
Code 93 

  
Code 93 encodes the full 128 ASCII character set using 9 modules arranged into 3 bars with adjacent 
spaces. Two of the characters are check characters. Code 93 is similar to Code 39 but encodes more 
characters per inch. Code 93 encodes the full 128 ASCII character set and is encoded similarly to Code 
39 Extended. 
  
Code 93 Example 
  

 
  
D 
 
Data Matrix 

  
Data Matrix is a 2D, variable length symbology capable of encoding all 128 ASCII characters and a 
number of different character sets. Each Data Matrix symbol consists of a perimeter quiet zone, border 
with two solid edges and two dashed edges, and cells inside the border which are dark or light. The 
border's two solid lines with data cells are used for symbol identification, orientation, and cell location. 
Data Matrix can accommodate up to 500 MB per square inch with a data capacity of 1 to 2335 
characters. Data Matrix has a high degree of redundancy and resists printing defects. 
  
Data Matrix is popular for labeling small products because it can encode many characters in a small 
area.  It is becoming the industry standard for marking small electronic equipment.  It is also used in the 
aeronautical industry and the US Department of Defense.  Data Matrix barcodes can be read by smart 
phones by downloading a reader. 
  
Data Matrix Example 
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E 
 
EAN/JAN  

  
The EAN/JAN-13 is fixed length and is similar to the UPC-A symbology, but encodes a 13th digit. Also, 
the "12th and 13th" digits of an EAN-13, may represent a country code in its entirety or just the 
beginning of the country code, which may vary from 2 to 3 digits. The code 00-04 and 06-09 are 
assigned to the United States. The nominal height for the EAN/JAN-13 bar code is one inch. The 
reduced size is 80% of the nominal size. 
   
The EAN/JAN-8 is fixed length and is similar to the UPC-E code, but includes two more digits for the 
country code. The nominal height for the EAN/JAN-8 bar code is one inch. The reduced size is 80% of 
the nominal size. 
  
EAN/JAN 8 Example 
  

 
  
EAN/JAN 13 Example 
  

 
  

G 
 
GS1 (Formerly RSS) 

  
The GS1 family contains three linear symbologies to be used with the GS1 (formerly EAN.UCC) 
system. The use of this symbology is intended to comply with the GS1 application guidelines. 
  
GS1 bar code symbols are intended for encoding identification numbers and data supplementary to the 
identification. The administration of the numbering system by GS1 ensures that identification codes 
assigned to particular items are unique worldwide and they and the associated supplementary data are 
defined in a consistent way. The major benefit for the users of the GS1 system is the availability of 
uniquely defined identification code and supplementary data formats for use in their trading 
transactions. 
  
GS1-14 encodes the full 14-digit GS1 item identification in a linear symbol that can be scanned 
omnidirectionally by suitably programmed point-of-sale scanners. 
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GS1-Limited encodes a 14-digit GS1 item identification with indicator digits of zero or one in a linear 
symbol for use on small items that will not be scanned at the point-of-sale. 
  
GS1-14 Stacked is a variation of GS1-14 symbology that is stacked in two rows and is used when the 
normal symbol would be too wide for the application. It comes in two versions – a truncated version 
used for small item marking applications, and a taller omnidirectional version that is designed to be read 
by omnidirectional scanners. 
  
GS1 Expanded encodes GS1 item identification plus supplementary AI element strings such as weight 
and "best before" date in a linear symbol that can be scanned omnidirectionally by suitably 
programmed point-of-sale scanners. GS1 Expanded can also be printed in multiple rows as a stacked 
column. 
  
GS1Stacked Omnidirectional allows the full height GS1-14 to be printed in two rows of two segments 
each, which reduces the overall length of the linear bar code so it can fit better on certain packaging 
configurations. The separator pattern between the two rows is designed to eliminate cross-row 
scanning errors. 
  
GS1 Truncated 
  
Any member of the GS1 family can be printed as a stand-alone linear symbol or as a composite symbol 
with an accompanying 2D Composite component printed directly above the GS1 linear component. 

 

GSI-128 (Formerly UCC/EAN 128) 

GS1-128 is a Serial Shipping Container Code with a secure bar code symbology. It allows all 
participants in the supply chain to use a common, standard solution for their individual tracking and 
tracing needs. 
  
The GS1-128 bar code symbology requires AIs to define the data architecture. AIs are prefixes which 
indicate the meaning and format of the data which follows. Among the things they  may be used for are 
 item identification, measurements, quantities, traceability, dates, transaction references and location 
numbers. 
  
 
GS1-128 Example 
  

 
I 

 

Interleaved 2 of 5 

  
Interleaved 2 of 5 is a variable length, even-numbered, numeric bar code symbol. It is typically used in 
industrial and master carton labeling. The symbology uses bars to represent the first character and the 
interleaved (white) spaces to represent the second character. Each character has two wide elements 
and three narrow elements.  A modulo 10 check character can be used to enhance data security for 
Interleaved 2 of 5 barcode symbols. When this option is selected, the last digit of the symbol is 
assumed to be the check digit, and it is compared to a calculated check digit to verify the symbol. 
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Interleaved 2 of 5 Example (No Check Digit) 
  

 
  

ISBN 

  
The International Standard Book Number (ISBN) is a unique machine-readable identification number 
used to identify books. ISBN is based on an ISO International Standard that was first published in 1972 
as ISO 2108. ISO 2108 specifies the basic structure of an ISBN, the rules for its allocation, and the 
administration of the ISBN system. 
  
ISBN barcodes have consisted of 13 digits since 2007.  Prior to 2007 they contained 13 digits.  An 
International Standard Book Number consists of 4 or 5 parts: 
  

 for a 13-digit ISBN, a GS1 (Code 128) prefix: 978 or 979 (indicating the industry; in this case, 
978 denotes book publishing) 

 the group identifier, (language-sharing country group) 
 the publisher code, 
 the item number, (title of the book) and 
 a check sum character or a check digit. 

  
The ISBN separates its parts (group, publisher, title and check digit) with either a hyphen or a space. 
Other than the check digit, no part of the ISBN will have a fixed number of digits 
  
ISBN Example 
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ITF14 

  
The ITF-14 Traded Unit Case Code is used in the retail sector on outer cases and pallets (traded units). 
Based on Interleaved 2 of 5, the 14-digit code is numeric and used to display the unique traded unit 
number. Bearer bars must be included in horizontal form for codes printed on labels, and as a full box 
(with H gauges) when printed directly on corrugated surfaces. 
  
ITF14 Example 
  

 
 

M 

 

MaxiCode 

  
Predominantly used by United Parcel Service to sort mail at high speed, MaxiCode is well suited to 
being read quickly and often in any direction. MaxiCode is a fixed-size 2D matrix barcode symbology 
having 866 hexagonal elements arranged in 33 rows around a central finder pattern. The size of a 
MaxiCode symbol is 1.1 inch by 1.05 inch. A single MaxiCode symbol can encode up to 93 characters 
of data and uses five different code sets to encode all 256 ASCII characters. MaxiCode uses three 
unique properties when encoding the data: Class of Service, Country Code, and Mode. 
  
Maxicode Example (Postal Code 75074, Country Code 840, Class of Service 003) 
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MicroPDF417 

  
MicroPDF417 is a multi-row 2D symbology, derived from and closely based on PDF417. It is designed 
for applications that need improved area efficiency but without the requirement for PDF417's maximum 
data capacity. A limited set of symbols is available, together with a fixed level of error correction for 
each symbol size. Module dimensions are user-specified to enable symbol production and reading by a 
wide variety of techniques. 
  
MicroPDF417 Example 
  

 
Micro QR Code 

  
Micro QR Code is a very small QR Code that fits applications that require a smaller space and use 
smaller amounts of data, such as ID of printed circuit boards and electronics parts, etc. 
  
Micro QR Code Example 
  

 
  
  

MSI 

  
The MSI character set consist of the numbers 0..9 as well as two "guard" characters (representing the 
beginning and end of the barcode). The symbology does not support alphabetic characters. 
  
MSI Example 
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P 
 
PDF417 

  
PDF417 is a stacked linear barcode symbol format used in a variety of applications, primarily transport, 
identification cards, and inventory management. PDF stands for Portable Data File.  Each character 
consists of 4 bars and 4 spaces in a 17 module structure. The name of the symbol is derived from the 
format of the code. PDF stands for "Portable Data File" and "417" is derived from the module structure. 
Each PDF417 symbol consists of 3 to 90 stacked rows surrounded by a quiet zone on all four sides. 
Each row consists of a leading quiet zone, start pattern, left row indicator character, one to thirty data 
characters, right row indicator character, stop pattern, and trailing quiet zone. 
   
PDF417 supports text compaction, numeric compaction, and byte compaction that correlate the 
mapping between codeword values and decoded data. PDF417 can accommodate up to 340 
characters per square inch with a maximum data capacity of 1850 text characters. 
  
PDF 417 Example 
  

 
  

POSTNET 

  
POSTNET (Postal Numeric Encoding Technique) is a barcode symbology that is used by the United 
States Postal Service to assist in directing mail. The ZIP Code or ZIP+4 code is encoded in half- and 
full-height bars. Most often, the delivery point is added, usually being the last two digits of the address 
or PO box number. 
  
The barcode starts and ends with a full bar (often called a guard rail or frame bar and represented as 
the letter "S" in one version of the USPS TrueType Font) and has a check digit after the ZIP, ZIP+4, or 
delivery point. The encoding table is shown on the right. 
  
Each individual digit is represented by a set of five bars, two of which are full bars (i.e. two-out-of-five 
code). The full bars represent "on" bits in a pseudo-binary code in which the places represent, from left 
to right: 7, 4, 2, 1, 0. (Though in this scheme, zero is encoded as 11 decimal, or "binary" 11000.) 
  
POSTNET Example 
  

 
  
  

PLANET 

  
PLANET stands for Postal AlphaNumeric Encoding Technique and is used by the United States Post 
Office to identify and track pieces of mail.  This barcode can be 12 or 14 digits long. 
  
PLANET Example 
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Q 
 
QR Code 

  
A QR code (abbreviated from Quick Response code) is a specific matrix barcode (or two-dimensional 
code) that is readable by dedicated QR barcode readers and camera telephones. The code consists of 
black modules arranged in a square pattern on a white background. The information encoded may be 
text, URL, or other data. 
  
QR Code Example 
  

 
 
U 
 
UPC-A 

  
Each UPC-A barcode consists of a scannable strip of black bars and white spaces, above a sequence 
of 12 numerical digits. No letters, characters, or other content of any kind may appear on a standard 
UPC-A barcode. The digits and bars maintain a one-to-one correspondence - in other words, there is 
only one way to represent each 12-digit number visually, and there is only one way to represent each 
visual barcode numerically. 
  
The UPC-A barcode is used on retail goods. 
  
UPC-A Example 
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